Blog Azeroth

A forum for World of Warcraft Bloggers
It is currently Thu Aug 28, 2014 11:05 am

All times are UTC




Post new topic Reply to topic  [ 7 posts ] 
Author Message
 Post subject: 2 quick, newbish WP questions
PostPosted: Tue Feb 05, 2008 11:46 pm 
Offline

Joined: Tue Feb 05, 2008 11:42 pm
Posts: 3
Location: Poland
Hey gang!

Long time reader, first time poster, amateur/beginning blogger! Great to be here.

My two small questions are these - I'd prefer to use the code section of the Writing template when I'm writing my posts, but whenever I save my draft WP seems to be doing funky things with my line breaks. What do you all use for line breaks? <br />, <p></p>, or do you stick with just writing normally in the Visual tab? My one attempt at just writing normally in the visual tab resulted in the same problem with WP gobbling up my paragraph seperations. Does anyone else have problems with this?

The second question I seem to have forgotten, but I'm sure I'll remember it soon. Thanks for the help!

Bartolo


Top
 WWW Profile Send private message  
 
 Post subject:
PostPosted: Tue Feb 05, 2008 11:56 pm 
Offline
User avatar

Joined: Tue Jan 22, 2008 10:59 pm
Posts: 89
Location: West Valley City, Utah
Server: Scarlet Crusade (US)
Great question. One of the addons that Phae and I have found that preserves your formating exactly is Alex King's WP Unformatted. You can find it on his website here. http://alexking.org/projects/wordpress

From his description:

Quote:
Description: With this enabled, you can add a custom field of 'sponge' set to '1' to a post to disable the auto formatting and a custom field of 'sandpaper' set to '1' to a post to disable the auto smart-quote conversion.


Um. I think that's what you're talking about. ^_^

_________________
http://www.parrydodgespin.com


Top
 WWW Profile Send private message  
 
 Post subject:
PostPosted: Wed Feb 06, 2008 12:00 am 
Offline

Joined: Tue Feb 05, 2008 11:42 pm
Posts: 3
Location: Poland
Thanks a ton! I just remembered my second question, but I think it may be related to my first, since it's also about line breaks: when I tab from code to visual, it does the same thing, undoing some line breaks, leaving others, its sorta weird. Maybe this plugin will do the trick. I'll keep you all posted!


Top
 WWW Profile Send private message  
 
 Post subject:
PostPosted: Wed Feb 06, 2008 12:08 am 
Offline

Joined: Tue Feb 05, 2008 11:42 pm
Posts: 3
Location: Poland
A ha! I just remembered my *real* second question:

Is there any way to control how big of a buffer I can put around images I place within my post? So the text doesn't run exactly right up to the image?


Top
 WWW Profile Send private message  
 
 Post subject:
PostPosted: Wed Feb 06, 2008 1:03 am 
Offline
User avatar

Joined: Wed Jan 23, 2008 1:39 am
Posts: 314
Location: Ner'Zhul, BC, Canada
Bartolo wrote:
A ha! I just remembered my *real* second question:

Is there any way to control how big of a buffer I can put around images I place within my post? So the text doesn't run exactly right up to the image?


That aspect is controlled in your presentation -> template -> style.css part. Look for something that says "img" in the stylesheet. You'll need to change the padding or the margin. I can't remember which.

img {

padding: 5 5 5 5;
margin: 5 5 5 5;
}

Of course, I may be totally wrong.

_________________
Matticus
"Power Through Knowledge and Reason"
http://www.worldofmatticus.com/
WoW Priest and Officer Blogger

Find me on GMail: matttz@gmail.com

Image


Top
 WWW Profile Send private message  
 
 Post subject:
PostPosted: Wed Feb 06, 2008 2:02 am 
Offline
User avatar

Joined: Thu Jan 24, 2008 6:27 am
Posts: 47
Location: Orlando, Florida
Server: Arthas
Imagine a box around the image you're using. Margins are the space around the outside of your image before the box starts while padding is the space outside the box before other things start.

_________________
They See Me Trollin'
Delmain - Troll Shadow Priest - Arthas (US)


Top
 WWW Profile Send private message  
 
 Post subject: the fix
PostPosted: Wed Feb 06, 2008 3:34 pm 
Offline
User avatar

Joined: Fri Feb 01, 2008 10:31 pm
Posts: 27
Location: Boston, MA
Hey bartolo, since you're writing for our blog it sho is funny posting a reply here instead of contacting you directly. But this might help others so here goes.

The problem is actually that when moving between visual and code post editors the <br> and <p> tags get removed. This may be due to a plug in installation or something, as some ppl claim on other wp forums.

Also, since after you bring up a draft post it automatically brings you into the visual editor, youre going to get the formatting removed. Same thing if you preview your post. When you jump back you're in visual so bye bye formatting.

To fix this get rid of the visual editor. That thing is for noobs anyway. You're hard core. You can handle it.

Log in to wp-admin. Go to the users tab and then the "your profile" sub-tab. There you can uncheck the "visual editor" box and pat yourself on the back for being such a hardcore leetist that you no longer need the visual editor. : )


Top
 WWW Profile Send private message  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 7 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
mergenine: WoW Alliance BB3
World of Warcraft ® ©2004-2007 Blizzard Entertainment, Inc. All rights reserved.