Blog Azeroth

A forum for World of Warcraft Bloggers
It is currently Sun Nov 23, 2014 1:24 pm

All times are UTC




Post new topic Reply to topic  [ 17 posts ] 
Author Message
 Post subject: How to force full RSS feeds with Wordpress?
PostPosted: Fri Jan 25, 2008 5:24 pm 
Offline

Joined: Fri Jan 25, 2008 3:03 pm
Posts: 36
Under Options-Reading-Syndication Feeds

I have the Full text radio box selected, but in my google reader- I keep getting partial feeds. Could this be my template forcing this somehow - or is there another way to make sure I get full RSS feeds?

Thanks,
Griff

_________________
Romans 1:18
WTFlux


Top
 WWW Profile Send private message  
 
 Post subject:
PostPosted: Fri Jan 25, 2008 5:42 pm 
Offline
User avatar

Joined: Thu Jan 24, 2008 12:32 am
Posts: 85
perhaps

Image

_________________
¨
http://yawown.blogspot.com/
¨


Top
 WWW Profile Send private message  
 
 Post subject:
PostPosted: Fri Jan 25, 2008 7:29 pm 
Offline

Joined: Fri Jan 25, 2008 3:03 pm
Posts: 36
Actually, it was happening before I joined feedburner. I'll check it out.

edit: mine was inactive too....

p.s. thanks for taking the time to screenshot that for me.

_________________
Romans 1:18
WTFlux


Top
 WWW Profile Send private message  
 
 Post subject:
PostPosted: Fri Jan 25, 2008 8:21 pm 
Offline
User avatar

Joined: Thu Jan 24, 2008 12:32 am
Posts: 85
WRATHofGOD wrote:

p.s. thanks for taking the time to screenshot that for me.


np.

I was wrong anyway, I noticed now your WP feed is partial also.

Don't know what could be the problem, perhaps some plugin.
Try changing your template maybe you're right; you can always change back if it won't do the trick.

_________________
¨
http://yawown.blogspot.com/
¨


Top
 WWW Profile Send private message  
 
 Post subject:
PostPosted: Fri Jan 25, 2008 8:59 pm 
Offline
User avatar

Joined: Tue Jan 22, 2008 10:07 pm
Posts: 361
Server: Scarlet Crusade (US)
Probably a silly question, but you aren't by chance using the <!-- More --> tags anywhere within your posts, are you?

_________________
Image
Healing with a positive carbon footprint.


Top
 WWW Profile Send private message  
 
 Post subject:
PostPosted: Fri Jan 25, 2008 9:14 pm 
Offline

Joined: Fri Jan 25, 2008 3:03 pm
Posts: 36
Naw, not a silly question but no, I'm not using the more tag. Kinda perplexing...

_________________
Romans 1:18
WTFlux


Top
 WWW Profile Send private message  
 
 Post subject:
PostPosted: Fri Jan 25, 2008 9:26 pm 
Offline
User avatar

Joined: Tue Jan 22, 2008 10:07 pm
Posts: 361
Server: Scarlet Crusade (US)
Are you up to trying this proposed solution?

http://wordpress.org/support/topic/107827

See the first response by Otto42, 5th response down.

_________________
Image
Healing with a positive carbon footprint.


Top
 WWW Profile Send private message  
 
 Post subject:
PostPosted: Mon Jan 28, 2008 4:29 pm 
Offline

Joined: Fri Jan 25, 2008 3:03 pm
Posts: 36
Code:
Find this code in wp-rss2.php

<?php if (get_option('rss_use_excerpt')) : ?>
      <description><![CDATA[<?php the_excerpt_rss() ?>]]></description>
<?php else : ?>
      <description><![CDATA[<?php the_excerpt_rss() ?>]]></description>

Change it to this:

<?php if (get_option('rss_use_excerpt')) : ?>
      <description><![CDATA[<?php the_excerpt_rss() ?>]]></description>
<?php else : ?>
      <description><![CDATA[<?php the_content_rss() ?>]]></description>


Arg. Tried that, and I'm still getting this problem. I guess I'll wait for another WP upgrade? :)

_________________
Romans 1:18
WTFlux


Top
 WWW Profile Send private message  
 
 Post subject:
PostPosted: Mon Jan 28, 2008 11:39 pm 
Offline
User avatar

Joined: Tue Jan 22, 2008 10:07 pm
Posts: 361
Server: Scarlet Crusade (US)
WoG,

Could you try installing Full Text Feed and seeing if that fixes your problem? Maybe something's just fubarred.

Phae

_________________
Image
Healing with a positive carbon footprint.


Top
 WWW Profile Send private message  
 
 Post subject:
PostPosted: Tue Jan 29, 2008 3:00 pm 
Offline

Joined: Fri Jan 25, 2008 3:03 pm
Posts: 36
I will definitely try! Thanks for the tip.

_________________
Romans 1:18
WTFlux


Top
 WWW Profile Send private message  
 
 Post subject:
PostPosted: Thu Jan 31, 2008 8:35 pm 
Offline

Joined: Fri Jan 25, 2008 3:03 pm
Posts: 36
*sigh*

I've tried everything.

Different templates, default template, disabling all plugins, etc. and still I get the teaser RSS feeds.

I guess I could re-install wordpress? Ugh.

_________________
Romans 1:18
WTFlux


Top
 WWW Profile Send private message  
 
 Post subject:
PostPosted: Thu Jan 31, 2008 10:52 pm 
Offline

Joined: Sun Jan 27, 2008 7:19 am
Posts: 25
Location: San Francisco, CA
Currently when I goto your site on the FD I see full text of posts.

When I view your RSS feed through bloglines I see full text on all your posts except for your test post. (which looks different currently in the RSS feed than the live version. So I'm guessing the RSS feed hasn't yet recached the story).


Please describe again, what are you trying to achieve?

_________________
Mystic Chicanery
http://chicanery.fibergeek.com/


Top
 WWW Profile Send private message  
 
 Post subject:
PostPosted: Fri Feb 01, 2008 9:42 pm 
Offline

Joined: Fri Jan 25, 2008 3:03 pm
Posts: 36
Huh...I use Google reader, and it's giving me partial feeds (in firefox and ie7) so I assumed that it was giving partial feeds everywhere.

Very odd...

_________________
Romans 1:18
WTFlux


Top
 WWW Profile Send private message  
 
 Post subject:
PostPosted: Mon Feb 04, 2008 2:40 pm 
Offline
User avatar

Joined: Thu Jan 24, 2008 2:31 pm
Posts: 98
Location: Atlanta, GA
a couple times you had it working, I noticed on my google reader, but then broke it again.. but the last test entry I saw worked perfectly.

still having troubles?

_________________
.
You might be a WoW noob if you....
Check out http://www.gamingnoobie.com/


Top
 WWW Profile Send private message  
 
 Post subject:
PostPosted: Mon Feb 04, 2008 7:44 pm 
Offline

Joined: Fri Jan 25, 2008 3:03 pm
Posts: 36
I just had a new post today, so we will see...

*fingers crossed*

_________________
Romans 1:18
WTFlux


Top
 WWW Profile Send private message  
 
 Post subject:
PostPosted: Tue Feb 05, 2008 8:35 pm 
Offline

Joined: Fri Jan 25, 2008 3:03 pm
Posts: 36
I've not seen a change, but something else completely hilarious is happening. I've own my domain, and I've got a personal blog. It is wordpress, same version, different template. IT GIVES ME FULL RSS FEEDS.

The settings are identical. I changed my WoW blog template and posted to see if it mattered. It didnt.

This is pretty crazy.

_________________
Romans 1:18
WTFlux


Top
 WWW Profile Send private message  
 
 Post subject:
PostPosted: Thu Feb 07, 2008 3:28 pm 
Offline

Joined: Fri Jan 25, 2008 3:03 pm
Posts: 36
I'm going to do some more testing. Would you guys mind helping out?

I'll toss out a test post, and you let me know if you get the full feed? (espcially if you use google reader)

This post (titled WP Default theme) is done with the default wordpress theme and will hopefully serve as a good control test.

Thanks for all your help.

_________________
Romans 1:18
WTFlux


Top
 WWW Profile Send private message  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 17 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
mergenine: WoW Alliance BB3
World of Warcraft ® ©2004-2007 Blizzard Entertainment, Inc. All rights reserved.